Discussion:
in_pcbbind() changes
(too old to reply)
Elad Efrat
2009-04-21 16:16:01 UTC
Permalink
Hey,

Attached is a diff implementing changes to in_pcbbind() similar to the
ones recently done in in6_pcbbind():

- Add in_pcbbind_{addr,port}() and split functionality
- Add in_pcbsetport() (almost an exact copy of in6_pcbsetport() that
was open-coded inside in_pcbbind())
- All three "static" for now, will be exposed if we decide to
- Fix a bug where "sin" was passed to kauth(9) without being set to
anything

Please review. :)

Thanks,

-e.
Mihai Chelaru
2009-05-09 20:46:10 UTC
Permalink
Post by Elad Efrat
Hey,
Attached is a diff implementing changes to in_pcbbind() similar to the
- Add in_pcbbind_{addr,port}() and split functionality
- Add in_pcbsetport() (almost an exact copy of in6_pcbsetport() that
was open-coded inside in_pcbbind())
- All three "static" for now, will be exposed if we decide to
- Fix a bug where "sin" was passed to kauth(9) without being set to
anything
Please review. :)
Hi,

You should check IN_MULTICAST(sin->sin_addr.s_addr) in in_pcbbind_addr()
and always succeed in that case.
--
Mihai

--
Posted automagically by a mail2news gateway at muc.de e.V.
Please direct questions, flames, donations, etc. to news-***@muc.de
Elad Efrat
2009-05-09 20:55:28 UTC
Permalink
On Sat, May 9, 2009 at 11:46 PM, Mihai Chelaru
You should check IN_MULTICAST(sin->sin_addr.s_addr) in in_pcbbind_addr() and
always succeed in that case.
You are correct, I had the check only in in_pcbbind_port(). Fixed, thanks!

-e.

--
Posted automagically by a mail2news gateway at muc.de e.V.
Please direct questions, flames, donations, etc. to news-***@muc.de
Loading...